Home Support

AVG Support Community

Share tips and solutions on AVG Products

Have a question?

Community topics

AVG Gurus

These community experts are here to help

  • (AB) Alan Binch
  • (BA) Borislav Angelov
  • (VB) Vladimir Bartl
  • (SK) Subhadeep Kanungo
  • (MS) Miloslav Serba
Ken RuniclesKen Runicles 

AVG Secure VPN

I pay a lot of money for AVG Secure VPN, and yet, during the last 2-3 days, when I click on the VPN icon, I am simply getting a blank white square where the VPN page should be. So I can't turn it on and I can do nothing, it just sits there and I can do nothing with it. Can anybody suggest how to solve this please?. 
Best Answer chosen by Ken Runicles
Bhuvaneswari VairavanBhuvaneswari Vairavan (Avast)
Ken, this issue happen when the Microsoft Visual C++ redristribute file http://download.microsoft.com/download/1/6/B/16B06F60-3B20-4FF2-B699-5E9B7962F9AE/VSU_4/vcredist_x64.exe is not up to date. Please make sure you have installed the lastest files and also check if the Secure VPN services is started.

If the issue persists, please reinstall the program once and check the status. If you face any difficulties, provide the screenshot (http://support.avg.com/SupportArticleView?urlname=How-to-create-a-screenshot) of the AVG Secure VPN screen to check and escalate the case.

All Answers

-980888528-980888528 (Avast)
Ken,

We request you to restart AVG Secure VPN service and check if it helps. Open run command by pressing Windows and R key simultaneously, type " services.msc " and enter. Click on AVG Secure VPN, select Restart service from left pane. Restart your device and check if it helps.
Ken RuniclesKen Runicles
Hi Ranjani,
I have tried what you say twice but, when I select AVG Secure VPN and 'restart', it starts to load (green bar) but then quickly stops. Consedquently, the software is still not available on my machine. Any new ideas please? Ken
-980888528-980888528 (Avast)
We appreciate your efforts, Ken. 

Sorry to hear that the issue persists. In such case, we need to reinstall it to fix the issue. 

Go to Control Panel -> Programs and features -> Uninstall -> uninstall AVG Secure VPN and reinstall it as suggested here: http://support.avg.com/SupportArticleView?urlname=Install-AVG-Secure-VPN
Ken RuniclesKen Runicles
Hi Ranjani,
Suddenly, this morning, after no new attempts to restore my AVG Secure VPN since Friday, I clicked on the icon and it worked again. I tried everything you said on Friday, to no avail. But here it is alive and kicking again! How does that happen and how do I prevent it happening again? And will I get an allowance of added subscription time for the week I've not had it? Ken
Bhuvaneswari VairavanBhuvaneswari Vairavan (Avast)
Ken, this issue happen when the Microsoft Visual C++ redristribute file http://download.microsoft.com/download/1/6/B/16B06F60-3B20-4FF2-B699-5E9B7962F9AE/VSU_4/vcredist_x64.exe is not up to date. Please make sure you have installed the lastest files and also check if the Secure VPN services is started.

If the issue persists, please reinstall the program once and check the status. If you face any difficulties, provide the screenshot (http://support.avg.com/SupportArticleView?urlname=How-to-create-a-screenshot) of the AVG Secure VPN screen to check and escalate the case.
This was selected as the best answer
Alan BinchAlan Binch
Ken, If applicable.. For your info, just in case that you are unaware, you can post the screenshot here in your topic. Click on 'Answer' & then click on the 'Image' [mountain symbol] & follow the instructions. 
AVG Guru
Ken RuniclesKen Runicles
All sorted now thanks. Seems to have rectified itself over the weekend, without any additional interventions by be. I really appreciate the advice, guys. Thank you.
KarthikeyanKarthikeyan (Avast) 
I am happy to hear that your issue is resolved.

I appreciate your time and co-operation.
Paul CramerPaul Cramer
I used the link provided to download the VPN and just reinstalled it and it works perfectly again.

Thanks.
Balasubramanian SBalasubramanian S (AVG) 
Glad to know that your issue has been resolved, Paul.
Feel free to contact us if you need assistance with AVG.
Have a nice day!!!
nazım bayernazım bayer

I am using windows 10 paid vpn subscription when I activate my connection is disconnected please help
KarthikeyanKarthikeyan (Avast) 
Hello Nazım,

We will work together to sort this issue.

Please remove and reinstall AVG Secure VPN on your computer and check if that fix the issue.

If the issue persists, please let us know and we will assist you further.
Milli MoreMilli More
Mine cannot be "accessed" today, no matter how many times I try, log off -on, etc.  I will not be renewing my subscription on this program!
Dinesh KrishnanDinesh Krishnan (AVG)
Hi Milli,

We're glad to look into this & help you.
Please let us know what happens exactly while accessing Secure VPN. Do you receive any error message?  If so, share us the screenshot of it for better clarity. 
To locate the product details & to help you with the appropriate support option, please write back to us in your own/individual post including the above requested info. 
Ask a question
Struggling with non-AVG technology? We can fix that, too!